using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+)(?=\/))(?!.*\1)";
string input = @"/designer-dev/22/Staging/Datawatch/English/hotfix/22.1.4/InternalBuild/1.2.3.44/AltairPanopticonVisualizationServerWAR_22-1-4.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}