import re
regex = re.compile(r"((\d+)(?=\/))(?!.*\1)", flags=re.MULTILINE)
test_str = "/designer-dev/22/Staging/Datawatch/English/hotfix/22.1.4/InternalBuild/1.2.3.44/AltairPanopticonVisualizationServerWAR_22-1-4.zip"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")