$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[-+=|,!@#$%&*^?_.~/\\\\(){}[\]<>])[A-Za-z\d-+=|,!@#$%&*^?_.~/\\\\(){}[\]<>]{8,}$/';
$str = 'Test-123@<>*&!~#$%^&*()__-=+/><.,.>}{}{[]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);