re = /(?>.*?([a-z])(?!.*\1)){26}/i
str = 'The quick brown fox jumps over a lazy dog.
Watch "Jeopardy!", Alex Trebek\'s fun TV quiz game.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end