# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[[^\][]+])(?<=\1.*\1)//gm;t' <<< "[John Smith][John Smith][Mr. Smith][Jane Doe][Mrs. Doe][John Smith][Jane Doe][Doe][John][Smith John][John Smith Sr]"