$re = '/(\[[^\][]+])(?<=\1.*\1)/m';
$str = '[John Smith][John Smith][Mr. Smith][Jane Doe][Mrs. Doe][John Smith][Jane Doe][Doe][John][Smith John][John Smith Sr]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;