const regex = /^(?=([1-5])\1*(?!\1)([1-5])(?:\1*\2){1,2}\1*$).{5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=([1-5])\\1*(?!\\1)([1-5])(?:\\1*\\2){1,2}\\1*$).{5}$', 'gm')
const str = `11122
11221
11212
12211
12121
12112
22111
21211
21121
21112
1122
111222
11223
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);