$re = '/^(?=([1-5])\1*(?!\1)([1-5])(?:\1*\2){1,2}\1*$).{5}$/m';
$str = '11122
11221
11212
12211
12121
12112
22111
21211
21121
21112
1122
111222
11223
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;