$re = '/(?i)#include\s*([<"])(.*)([>"])/m';
$str = '#include <File.au3>
#include"Help.au3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);