re = /(?i)#include\s*([<"])(.*)([>"])/m
str = '#include <File.au3>
#include"Help.au3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end