using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\W|^)(\+?\d{1,3})?( |-)?\(?\d{3}\)?( |-)?\d{3}( |-)?\d{4}\b";
string input = @"+38 911 994 1104
+38 911 994 1104";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}