$re = '/(?<=\W|^)(\+?\d{1,3})?( |-)?\(?\d{3}\)?( |-)?\d{3}( |-)?\d{4}\b/m';
$str = '+38 911 994 1104
+38 911 994 1104';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);