package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)(?<delim>\s*\/\s*)(.*$)`)
var str = `My Artist One / My Artist Two / Another Guy`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}