re = /(.*?)(?<delim>\s*\/\s*)(.*$)/
str = 'My Artist One / My Artist Two / Another Guy'
# Print the match result
str.match(re) do |match|
puts match.to_s
end