import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,3}(?:[^\\S\\n]?\\d{3})*(?:,\\d+)?(?!\\d)";
final String string = "1\n"
+ "100 543,55\n"
+ "100542,55\n"
+ "1,123\n"
+ "123 124,55\n"
+ "1 235,66\n"
+ "67\n"
+ "1234,66\n"
+ "12,4\n"
+ "123456789\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}