$re = '/\.\/resources\/red_([^.]+)/m';
$str = './resources/red_B.png
./resources/red_1.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);