const regex = /(?i)^(\s*[a-z0-9. ]{1,10}(?=\s|$)){0,5}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^(\\s*[a-z0-9. ]{1,10}(?=\\s|$)){0,5}', 'gm')
const str = `this is line one
this is line two
this is line three
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}