$re = '/(?i)^(\s*[a-z0-9. ]{1,10}(?=\s|$)){0,5}/m';
$str = 'this is line one
this is line two
this is line three
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);