import re
regex = re.compile(r"^(h[1-6]|p|a|img):\n[\w\-\.\d].*(?=\n{0,}?)", flags=re.MULTILINE)
test_str = ("h3:\n"
"Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.\n\n"
"h4:\n"
"Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.\n\n"
"p:\n"
"Hello this is a paragraph you can add something to our dsle deglet for more and now how to use this for free\n\n"
"img:\n"
"http://www.icon.in/logoe/gksoedfkle/dfkeadka/img.jpg\n\n"
"a:\n"
"rahul\n\n"
"p:\n"
"are you ready for more thing so what do you think\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)