re = /\s/m
str = 'Почему регулярка не видит пробел? Потому что это был особый пробел.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end