using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h2>[\w\W]+?(?=\s+<h2>|\s*$)";
string input = @"<h1>Hot Topics in AI Search Engines</h1>
<h2>1. Neural Search</h2>
<p>Neural search is a technique that uses deep learning models to improve the relevance and accuracy of search results. It has the potential to significantly enhance the search experience for users.</p>
<h2>2. Semantic Search</h2>
<p>Semantic search is the use of natural language processing and machine learning to understand the intent and context of a user's search query. It can help search engines provide more accurate and relevant results.</p>
<h2>3. Conversational Search</h2>
<p>Conversational search is a type of search that allows users to interact with search engines using natural language conversations. It has the potential to make search more intuitive and user-friendly.</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}