const regex = /<h2>[\w\W]+?(?=\s+<h2>|\s*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h2>[\\w\\W]+?(?=\\s+<h2>|\\s*$)', 'g')
const str = `<h1>Hot Topics in AI Search Engines</h1>
<h2>1. Neural Search</h2>
<p>Neural search is a technique that uses deep learning models to improve the relevance and accuracy of search results. It has the potential to significantly enhance the search experience for users.</p>
<h2>2. Semantic Search</h2>
<p>Semantic search is the use of natural language processing and machine learning to understand the intent and context of a user's search query. It can help search engines provide more accurate and relevant results.</p>
<h2>3. Conversational Search</h2>
<p>Conversational search is a type of search that allows users to interact with search engines using natural language conversations. It has the potential to make search more intuitive and user-friendly.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}