$re = '/(?<=\\\\)(?<theWord>[\w\.]+)$/m';
$str = '\\hostname\\bs\\cf\\webservice\\Wordto2Extract.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);