re = /(?<=\\)(?<theWord>[\w\.]+)$/m
str = '\\hostname\\bs\\cf\\webservice\\Wordto2Extract.exe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end