using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\$?[A-Za-z_][A-Za-z_0-9.]*):)?([A-Za-z_][A-Za-z_0-9.]*)\(((.*,)*(.*))\)";
string input = @"str test = ""ee"";
call $std:console.print(test);
call $std:window.resize(1280, 720);
call test(""test"");";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}