re = /((\$?[A-Za-z_][A-Za-z_0-9.]*):)?([A-Za-z_][A-Za-z_0-9.]*)\(((.*,)*(.*))\)/m
str = 'str test = "ee";
call $std:console.print(test);
call $std:window.resize(1280, 720);
call test("test");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end