using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bs\.l\.(?!\w)";
string input = @"aaa s.l. bbb
aaa s.l.bbb
aaa s.l., bbb";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}