using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\ba\.";
string input = @" a. this is a test string a. test string.some records like a.is";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}