# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)\s*"
test_str = ("1 Question\n"
"2 Answer 1\n"
"3 Answer 2\n"
"4 Answer 3\n"
"5 Answer 4\n"
"6 Answer 5\n"
"7 Question\n"
"8 Answer 1\n"
"9 Answer 2\n"
"10 Answer 3\n"
"11 Answer 4\n"
"12 Answer 5")
subst = "<h1>$1</h1><p>$2</p><br><p>$3</p><br><p>$4</p><br><p>$5</p>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.