// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)\s*").unwrap();
let string = "1 Question
2 Answer 1
3 Answer 2
4 Answer 3
5 Answer 4
6 Answer 5
7 Question
8 Answer 1
9 Answer 2
10 Answer 3
11 Answer 4
12 Answer 5";
let substitution = "<h1>$1</h1><p>$2</p><br><p>$3</p><br><p>$4</p><br><p>$5</p>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}