import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bafter[\\s_:.,()-]+|\\bnach[\\s_:.,()-]+|\\bd'apres[\\s_:.,()-]+|\\bd´apres[\\s_:.,()-]+|\\bCircle of[\\s_:.,()-]+)*(Pablo[\\s_:.,()-]+Picasso|Picasso[\\s_:.,()-]+Pablo)([\\s_:.,()-]+Nachfolge\\b|[\\s_:.,()-]+Nachfolger\\b|[\\s_:.,()-]+Nachfolgerin\\b|[\\s_:.,()-]+Werkstatt\\b|[\\s_:.,()-]+Umkreis\\b|[\\s_:.,()-]+d'apres\\b|[\\s_:.,()-]+d´apres\\b|[\\s_:.,()-]+Circle of\\b)*";
final String string = "This is a test Picasso, Pablo bla\n"
+ "This is a test after Pablo Picasso (d'apres)";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}