const regex = /(\bafter[\s_:.,()-]+|\bnach[\s_:.,()-]+|\bd'apres[\s_:.,()-]+|\bd´apres[\s_:.,()-]+|\bCircle of[\s_:.,()-]+)*(Pablo[\s_:.,()-]+Picasso|Picasso[\s_:.,()-]+Pablo)([\s_:.,()-]+Nachfolge\b|[\s_:.,()-]+Nachfolger\b|[\s_:.,()-]+Nachfolgerin\b|[\s_:.,()-]+Werkstatt\b|[\s_:.,()-]+Umkreis\b|[\s_:.,()-]+d'apres\b|[\s_:.,()-]+d´apres\b|[\s_:.,()-]+Circle of\b)*/uimg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bafter[\\s_:.,()-]+|\\bnach[\\s_:.,()-]+|\\bd\'apres[\\s_:.,()-]+|\\bd´apres[\\s_:.,()-]+|\\bCircle of[\\s_:.,()-]+)*(Pablo[\\s_:.,()-]+Picasso|Picasso[\\s_:.,()-]+Pablo)([\\s_:.,()-]+Nachfolge\\b|[\\s_:.,()-]+Nachfolger\\b|[\\s_:.,()-]+Nachfolgerin\\b|[\\s_:.,()-]+Werkstatt\\b|[\\s_:.,()-]+Umkreis\\b|[\\s_:.,()-]+d\'apres\\b|[\\s_:.,()-]+d´apres\\b|[\\s_:.,()-]+Circle of\\b)*', 'uimg')
const str = `This is a test Picasso, Pablo bla
This is a test after Pablo Picasso (d'apres)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}