re = /\b([A-F 0-9]{8})-([A-F 0-9]{4})-([A-F 0-9]{4})-([A-F 0-9]{4})-([A-F 0-9]{12})\b/i
str = '3a0decee-ca3a-4f39-b3e4-8df6bd25616b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end