using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^|$";
string input = @"Line 1
Line 2
Line 3
Line 4
Line 5
Line 6";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}