package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^|$`)
var str = `Line 1
Line 2
Line 3
Line 4
Line 5
Line 6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}