package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4}.?){4}`)
var str = ` 2131 2312 1231 3675 4397 3868 0
12332312231231233675 4532 232345 55 345235`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}