$re = '/(\d{4}.?){4}/m';
$str = ' 2131 2312 1231 3675 4397 3868 0
12332312231231233675 4532 232345 55 345235';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);