import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^(?=.* ABN \\d{2}(?: \\d{3}){3}\\n(?P<products>.*\\n)Qty\\n).*\\n\\$\\d+\\.\\d{2}\\n(?P<subtotal>\\d+) +SUBTOTAL\\.*\\nTOTAL\\n\\$(?P<total>\\d+\\.\\d{2})\\n";
final String string = "ㅎㅎ\n"
+ "Fresh Food\n"
+ "The fresh food people\n"
+ "5619 Lorem PH: 00 0000 0000\n"
+ "204 Some Road\n"
+ "TAX INVOICE - ABN 88 000 014 675\n"
+ "Gift Card Visa Varbl 20to500Dollars\n"
+ "Potato White Washed 2Kg\n"
+ "Nescafe Coffee Blend 43 50g\n"
+ "^HToblerone Milk Chocolate Bar 50g\n"
+ "^HOreo Cookie Original 133g\n"
+ "#M&Ms Crispy 145g\n"
+ "*HRed Rock Deli Portgse Chicken 150g\n"
+ "^HWrigleys Extra Pepprmint 14pc 27g(?.*\n"
+ "Qty\n"
+ "57.95\n"
+ "3.50\n"
+ "5.00\n"
+ "0.90\n"
+ "1.50\n"
+ "4.50\n"
+ "3.50\n"
+ "2 @ $1.80\n"
+ "each\n"
+ "3.60\n"
+ "$80.45\n"
+ "9 SUBTOTAL\n"
+ "TOTAL\n"
+ "$80.45\n"
+ "REWARDS SAVINGS\n"
+ "$10.00\n"
+ "Fresh Food\n"
+ "5619\n"
+ "Lorem";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}