# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)^(?=.* ABN \d{2}(?: \d{3}){3}\n(?P<products>.*\n)Qty\n).*\n\$\d+\.\d{2}\n(?P<subtotal>\d+) +SUBTOTAL\.*\nTOTAL\n\$(?P<total>\d+\.\d{2})\n"
test_str = ("ㅎㅎ\n"
"Fresh Food\n"
"The fresh food people\n"
"5619 Lorem PH: 00 0000 0000\n"
"204 Some Road\n"
"TAX INVOICE - ABN 88 000 014 675\n"
"Gift Card Visa Varbl 20to500Dollars\n"
"Potato White Washed 2Kg\n"
"Nescafe Coffee Blend 43 50g\n"
"^HToblerone Milk Chocolate Bar 50g\n"
"^HOreo Cookie Original 133g\n"
"#M&Ms Crispy 145g\n"
"*HRed Rock Deli Portgse Chicken 150g\n"
"^HWrigleys Extra Pepprmint 14pc 27g(?.*\n"
"Qty\n"
"57.95\n"
"3.50\n"
"5.00\n"
"0.90\n"
"1.50\n"
"4.50\n"
"3.50\n"
"2 @ $1.80\n"
"each\n"
"3.60\n"
"$80.45\n"
"9 SUBTOTAL\n"
"TOTAL\n"
"$80.45\n"
"REWARDS SAVINGS\n"
"$10.00\n"
"Fresh Food\n"
"5619\n"
"Lorem")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.