const regex = /^h[1,3,5]\-ars0(?:[1-5]\-v|[6,7])\.eset\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^h[1,3,5]\\-ars0(?:[1-5]\\-v|[6,7])\\.eset\\.com$', 'gmi')
const str = `h1-ars01-v.eset.com
h1-ars02-v.eset.com
h1-ars03-v.eset.com
h1-ars04-v.eset.com
h1-ars05-v.eset.com
h1-ars06.eset.com
h1-ars07.eset.com
h3-ars01-v.eset.com
h3-ars02-v.eset.com
h3-ars03-v.eset.com
h3-ars04-v.eset.com
h3-ars05-v.eset.com
h3-ars06.eset.com
h3-ars07.eset.com
h5-ars01-v.eset.com
h5-ars02-v.eset.com
h5-ars03-v.eset.com
h5-ars04-v.eset.com
h5-ars05-v.eset.com
h5-ars06.eset.com
h5-ars07.eset.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}