$re = '/.*[^c|p]\/.*/m';
$str = 'c/this-should-not-match
p/this-should-not-match
p/
c/
z/this-should-match
product/this-should-match
collection/this-should-match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);