// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*[^c|p]\/.*").unwrap();
let string = "c/this-should-not-match
p/this-should-not-match
p/
c/
z/this-should-match
product/this-should-match
collection/this-should-match";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}