#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\(?(?:0(?:0|11)\)?[\s-]?\(?|\+)44\)?[\s-]?(?:\(?0\)?[\s-]?)?)|(?:\(?0))(?:(?:\d{5}\)?[\s-]?\d{4,5})|(?:\d{4}\)?[\s-]?(?:\d{5}|\d{3}[\s-]?\d{3}))|(?:\d{3}\)?[\s-]?\d{3}[\s-]?\d{3,4})|(?:\d{2}\)?[\s-]?\d{4}[\s-]?\d{4}))(?:[\s-]?(?:x|ext\.?|\#)\d{3,4})?$"
Local $sString = "# Using patterns from here:" & @CRLF & _
"# http://www.area-codes.org.uk/formatting.php" & @CRLF & _
"# Regex found here:" & @CRLF & _
"# https://stackoverflow.com/a/31589527/863062" & @CRLF & _
"" & @CRLF & _
"01999 99999" & @CRLF & _
"01999 999999" & @CRLF & _
"0119 999 9999" & @CRLF & _
"0191 999 9999" & @CRLF & _
"013873 99999" & @CRLF & _
"015242 99999" & @CRLF & _
"015394 99999" & @CRLF & _
"015395 99999" & @CRLF & _
"015396 99999" & @CRLF & _
"016973 99999" & @CRLF & _
"016974 99999" & @CRLF & _
"016977 9999" & @CRLF & _
"016977 99999" & @CRLF & _
"017683 99999" & @CRLF & _
"017684 99999" & @CRLF & _
"017687 99999" & @CRLF & _
"019467 99999" & @CRLF & _
"029 9999 9999" & @CRLF & _
"0399 999 9999" & @CRLF & _
"05999 999999" & @CRLF & _
"07999 999999" & @CRLF & _
"0800 999999" & @CRLF & _
"0899 999 9999" & @CRLF & _
"0999 999 9999" & @CRLF & _
"" & @CRLF & _
"+441999 99999" & @CRLF & _
"+441999 999999" & @CRLF & _
"+44119 999 9999" & @CRLF & _
"+44191 999 9999" & @CRLF & _
"+4413873 99999" & @CRLF & _
"+4415242 99999" & @CRLF & _
"+4415394 99999" & @CRLF & _
"+4415395 99999" & @CRLF & _
"+4415396 99999" & @CRLF & _
"+4416973 99999" & @CRLF & _
"+4416974 99999" & @CRLF & _
"+4416977 9999" & @CRLF & _
"+4416977 99999" & @CRLF & _
"+4417683 99999" & @CRLF & _
"+4417684 99999" & @CRLF & _
"+4417687 99999" & @CRLF & _
"+4419467 99999" & @CRLF & _
"+4429 9999 9999" & @CRLF & _
"+44399 999 9999" & @CRLF & _
"+445999 999999" & @CRLF & _
"+447999 999999" & @CRLF & _
"+44800 999999" & @CRLF & _
"+44899 999 9999" & @CRLF & _
"+44999 999 9999" & @CRLF & _
"" & @CRLF & _
"+44 1999 99999" & @CRLF & _
"+44 1999 999999" & @CRLF & _
"+44 119 999 9999" & @CRLF & _
"+44 191 999 9999" & @CRLF & _
"+44 13873 99999" & @CRLF & _
"+44 15242 99999" & @CRLF & _
"+44 15394 99999" & @CRLF & _
"+44 15395 99999" & @CRLF & _
"+44 15396 99999" & @CRLF & _
"+44 16973 99999" & @CRLF & _
"+44 16974 99999" & @CRLF & _
"+44 16977 9999" & @CRLF & _
"+44 16977 99999" & @CRLF & _
"+44 17683 99999" & @CRLF & _
"+44 17684 99999" & @CRLF & _
"+44 17687 99999" & @CRLF & _
"+44 19467 99999" & @CRLF & _
"+44 29 9999 9999" & @CRLF & _
"+44 399 999 9999" & @CRLF & _
"+44 5999 999999" & @CRLF & _
"+44 7999 999999" & @CRLF & _
"+44 800 999999" & @CRLF & _
"+44 899 999 9999" & @CRLF & _
"+44 999 999 9999" & @CRLF & _
"" & @CRLF & _
"00441999 99999" & @CRLF & _
"00441999 999999" & @CRLF & _
"0044119 999 9999" & @CRLF & _
"0044191 999 9999" & @CRLF & _
"004413873 99999" & @CRLF & _
"004415242 99999" & @CRLF & _
"004415394 99999" & @CRLF & _
"004415395 99999" & @CRLF & _
"004415396 99999" & @CRLF & _
"004416973 99999" & @CRLF & _
"004416974 99999" & @CRLF & _
"004416977 9999" & @CRLF & _
"004416977 99999" & @CRLF & _
"004417683 99999" & @CRLF & _
"004417684 99999" & @CRLF & _
"004417687 99999" & @CRLF & _
"004419467 99999" & @CRLF & _
"004429 9999 9999" & @CRLF & _
"0044399 999 9999" & @CRLF & _
"00445999 999999" & @CRLF & _
"00447999 999999" & @CRLF & _
"0044800 999999" & @CRLF & _
"0044899 999 9999" & @CRLF & _
"0044999 999 9999" & @CRLF & _
"" & @CRLF & _
"0044 1999 99999" & @CRLF & _
"0044 1999 999999" & @CRLF & _
"0044 119 999 9999" & @CRLF & _
"0044 191 999 9999" & @CRLF & _
"0044 13873 99999" & @CRLF & _
"0044 15242 99999" & @CRLF & _
"0044 15394 99999" & @CRLF & _
"0044 15395 99999" & @CRLF & _
"0044 15396 99999" & @CRLF & _
"0044 16973 99999" & @CRLF & _
"0044 16974 99999" & @CRLF & _
"0044 16977 9999" & @CRLF & _
"0044 16977 99999" & @CRLF & _
"0044 17683 99999" & @CRLF & _
"0044 17684 99999" & @CRLF & _
"0044 17687 99999" & @CRLF & _
"0044 19467 99999" & @CRLF & _
"0044 29 9999 9999" & @CRLF & _
"0044 399 999 9999" & @CRLF & _
"0044 5999 999999" & @CRLF & _
"0044 7999 999999" & @CRLF & _
"0044 800 999999" & @CRLF & _
"0044 899 999 9999" & @CRLF & _
"0044 999 999 9999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")