import re
regex = re.compile(r"^(?:(?:\(?(?:0(?:0|11)\)?[\s-]?\(?|\+)44\)?[\s-]?(?:\(?0\)?[\s-]?)?)|(?:\(?0))(?:(?:\d{5}\)?[\s-]?\d{4,5})|(?:\d{4}\)?[\s-]?(?:\d{5}|\d{3}[\s-]?\d{3}))|(?:\d{3}\)?[\s-]?\d{3}[\s-]?\d{3,4})|(?:\d{2}\)?[\s-]?\d{4}[\s-]?\d{4}))(?:[\s-]?(?:x|ext\.?|\#)\d{3,4})?$", flags=re.MULTILINE)
test_str = ("# Using patterns from here:\n"
"# http://www.area-codes.org.uk/formatting.php\n"
"# Regex found here:\n"
"# https://stackoverflow.com/a/31589527/863062\n\n"
"01999 99999\n"
"01999 999999\n"
"0119 999 9999\n"
"0191 999 9999\n"
"013873 99999\n"
"015242 99999\n"
"015394 99999\n"
"015395 99999\n"
"015396 99999\n"
"016973 99999\n"
"016974 99999\n"
"016977 9999\n"
"016977 99999\n"
"017683 99999\n"
"017684 99999\n"
"017687 99999\n"
"019467 99999\n"
"029 9999 9999\n"
"0399 999 9999\n"
"05999 999999\n"
"07999 999999\n"
"0800 999999\n"
"0899 999 9999\n"
"0999 999 9999\n\n"
"+441999 99999\n"
"+441999 999999\n"
"+44119 999 9999\n"
"+44191 999 9999\n"
"+4413873 99999\n"
"+4415242 99999\n"
"+4415394 99999\n"
"+4415395 99999\n"
"+4415396 99999\n"
"+4416973 99999\n"
"+4416974 99999\n"
"+4416977 9999\n"
"+4416977 99999\n"
"+4417683 99999\n"
"+4417684 99999\n"
"+4417687 99999\n"
"+4419467 99999\n"
"+4429 9999 9999\n"
"+44399 999 9999\n"
"+445999 999999\n"
"+447999 999999\n"
"+44800 999999\n"
"+44899 999 9999\n"
"+44999 999 9999\n\n"
"+44 1999 99999\n"
"+44 1999 999999\n"
"+44 119 999 9999\n"
"+44 191 999 9999\n"
"+44 13873 99999\n"
"+44 15242 99999\n"
"+44 15394 99999\n"
"+44 15395 99999\n"
"+44 15396 99999\n"
"+44 16973 99999\n"
"+44 16974 99999\n"
"+44 16977 9999\n"
"+44 16977 99999\n"
"+44 17683 99999\n"
"+44 17684 99999\n"
"+44 17687 99999\n"
"+44 19467 99999\n"
"+44 29 9999 9999\n"
"+44 399 999 9999\n"
"+44 5999 999999\n"
"+44 7999 999999\n"
"+44 800 999999\n"
"+44 899 999 9999\n"
"+44 999 999 9999\n\n"
"00441999 99999\n"
"00441999 999999\n"
"0044119 999 9999\n"
"0044191 999 9999\n"
"004413873 99999\n"
"004415242 99999\n"
"004415394 99999\n"
"004415395 99999\n"
"004415396 99999\n"
"004416973 99999\n"
"004416974 99999\n"
"004416977 9999\n"
"004416977 99999\n"
"004417683 99999\n"
"004417684 99999\n"
"004417687 99999\n"
"004419467 99999\n"
"004429 9999 9999\n"
"0044399 999 9999\n"
"00445999 999999\n"
"00447999 999999\n"
"0044800 999999\n"
"0044899 999 9999\n"
"0044999 999 9999\n\n"
"0044 1999 99999\n"
"0044 1999 999999\n"
"0044 119 999 9999\n"
"0044 191 999 9999\n"
"0044 13873 99999\n"
"0044 15242 99999\n"
"0044 15394 99999\n"
"0044 15395 99999\n"
"0044 15396 99999\n"
"0044 16973 99999\n"
"0044 16974 99999\n"
"0044 16977 9999\n"
"0044 16977 99999\n"
"0044 17683 99999\n"
"0044 17684 99999\n"
"0044 17687 99999\n"
"0044 19467 99999\n"
"0044 29 9999 9999\n"
"0044 399 999 9999\n"
"0044 5999 999999\n"
"0044 7999 999999\n"
"0044 800 999999\n"
"0044 899 999 9999\n"
"0044 999 999 9999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")