#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*\bLAST_DOMINO_TIME=.*$)^.*$"
Local $sString = "This is a test" & @CRLF & _
"test=asda" & @CRLF & _
"test2=22rr2" & @CRLF & _
"LAST_DOMINO_TIME=3242ffs3F34" & @CRLF & _
"test5=hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")