$re = '/^[0-9]{1,3}(?::[0-9]{1,3})*:?$/m';
$str = '12
12:30
123:20:
1:20:
123::20:
12::20:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);