import re
regex = re.compile(r"^[0-9]{1,3}(?::[0-9]{1,3})*:?$", flags=re.MULTILINE)
test_str = ("12\n"
"12:30\n"
"123:20:\n"
"1:20:\n\n"
"123::20:\n"
"12::20:\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")