package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<image>[a-z0-9.\-_]+(?:/[a-z0-9.\-_]+|))(:(?<tag>[\w.\-_]{1,127})|)$`)
var str = `alpine
alpine:latest
_/alpine
_/alpine:latest
alpine:3.7
pse/anabroker:latest
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}