re = /^(?<image>[a-z0-9.\-_]+(?:\/[a-z0-9.\-_]+|))(:(?<tag>[\w.\-_]{1,127})|)$/m
str = 'alpine
alpine:latest
_/alpine
_/alpine:latest
alpine:3.7
pse/anabroker:latest
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end