using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?:\\.|[^\\""])*""|'(?:\\.|[^\\'])*'|[^\s""']+";
string input = @"Lorem ipsum (""dolor sit amet"") consectetur ""adipiscing \""elit"" dolor 'something here'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}